00:31 ppw: where should I start diagnosing no DVI output (when there is VGA output under nouveau and the card is capable of DVI output with proprietary drivers)?
00:49 pabs: ppw: not a dev, but did you run through the troubleshooting guide? https://nouveau.freedesktop.org/TroubleShooting.html
00:49 pabs: also check dmesg with nouveau and maybe the same with proprietary drivers
01:02 ppw: dmesg shows no issues apart from spurious "bus: MMIO write of 00510002 FAULT at 00c200" messages, which I suspect have to deal with the backlight.
01:04 ppw: as for the proprietary drivers, that would require loading up a distribution that contains the 304.xx version. the kernel versions that correspond to that driver version either panic at boot or lock up after a few minutes, unless ACPI is turned off, in which case only one core works.
01:08 ppw: I've used some additional boot parameters to get more debugging information, "log_buf_len=1M drm.debug=14 nouveau.reg_debug=0x0200 3", but there's no issues - it even shows the process of the detecting the DVI-connected display and setting it up. and xrandr shows it as connected and working. the sil164 module that enables DVI output is also loaded automatically.
01:09 karolherbst: ppw: huh.. sil164?
01:09 karolherbst: ohh, yeah..
01:09 ppw: https://cateee.net/lkddb/web-lkddb/DRM_I2C_SIL164.html
01:09 karolherbst: what GPU is that? but I suspect it's some older one, isn't it?
01:10 ppw: yes. it's a G71GLM (FX1500M).
01:10 karolherbst: could be that we broke that.. dunno
01:10 karolherbst: was it like always broken?
01:12 ppw: nouveau only recently began to work semi-decent well with this gpu. usually, I would get garbled display at boot. but since installing a more recent kernel version (later than 5.10), it works decently -- until there's animation involved.
01:13 karolherbst: ahh
01:13 karolherbst: yeah.. GL is quite a broken mess on those old GPUs
01:13 karolherbst: we've fixed a few issues, but you are better of not using GL
01:14 karolherbst: might be worth to investigate those issues though
01:14 karolherbst: as about DVI.. no clue. I suspect we configure the GPU wrongly
01:14 ppw: but .. why would it work OK with VGA?
01:15 karolherbst: because VGA isn't DVI :P
23:08 ppw: how would I .. measure GPU usage on linux?