02:48 imirkin: anholt: i'm a bit surprised you've had such a hard time getting a nv47 to run. perhaps that one has some extra-special issues. i do most of my testing on nv42 or nv44.
02:49 imirkin: anholt: i'm going to try to swap one of those into my desktop over the weekend and see what's up
02:50 imirkin: anholt: wrt depth stuff, we definitely drop zeta surfaces on the floor sometimes. basically the hw wants zeta-bitness == color-bitness. so if they don't match, we just don't bind zeta. but that shouldn't cause crashes, just misrendering.
05:22 anholt: imirkin: I don't think I was having any depth-specific issues, it was just a "trivial rendering test that shows how thoroughly unstable things are"
19:49 ilgaz: there is a mysterious issue on macbook (nvidia 9400m) at work. It turns off the laptop display at random times, saw some messages about being unable to load firmware but it is for video acceleration only right?
19:50 ilgaz: of course all "turn off display" settings are off on KDE
19:50 ilgaz: hopefully not another KDE bug btw
21:35 RSpliet: ilgaz: isn't that the dreaded NVAC?
21:36 RSpliet: Dreaded because iirc specifically the Mac one had troubles. I had an NVAC on an Atom board that never gave me any beef.
22:00 RSpliet: Lyude: Am I supposed to be able to set NvFbBigPage=16 on GK104? It seems to all work, apart from how the cursor is now really really weirdly stretched out
22:03 RSpliet: In screenshots the cursor looks fine, what a hack!
22:08 RSpliet: https://imgur.com/a/Gj2UFiD The smudgy trellis on the centre right is a vertically stretched black cursor
23:34 anholt: ah, the arm soc joys: what magic kernel config am I missing to probe tegra drm
23:34 anholt: (got the jetson nano to boot at last, which means that I may be able to turn it into a ci bot)
23:36 RSpliet: I hear ARM board bring-up procedures have gotten exactly 0% better in the past 10 years
23:40 ilgaz: RSpliet: exactly :-( NVAC . bbl
23:40 anholt: devicetree did successfully make things different!
23:42 pabs: isn't ARM in the process of switching to UEFI?