19:43 bitblit: i've been using nouveau without issues on Arch. just came across the nouveau-fw package, why might i need that?
19:47 imirkin: never.
19:47 imirkin: actually, i dunno what's in that package. got a link?
19:48 imirkin: if it's what i think it is, then never
19:48 bitblit: https://aur.archlinux.org/packages/nouveau-fw/
19:48 imirkin: ah no
19:48 imirkin: that one's not the never one
19:48 imirkin: that one's the video decoding firmware
19:48 imirkin: bitblit: https://nouveau.freedesktop.org/VideoAcceleration.html
19:50 imirkin: mupuf: can you update the extract_firmware.py to point at the one in https://github.com/envytools/firmware ?
19:50 imirkin: that version also has py3 support nowadays
19:50 bitblit: originally i noticed this error in journalctl which led me to that package: "Direct firmware load for nouveau/nv106_fuc084 failed with error -2"
19:51 imirkin: bitblit: yeah. if you want to use vdpau (or va-api) hw-accelerated decoding
19:51 imirkin: then you need the firmware
19:51 imirkin: otherwise you don't
19:51 bitblit: thanks i'll probably give it a try.
19:59 test65: What family does the gtx 870m go under? Its not listed under codenames on freedesktop. I'd imagine it would be GM10x
20:08 imirkin: test65: according to pci.ids, seems like GK104M
20:08 imirkin: i.e. kepler
20:08 test65: tyvm
20:08 imirkin: you can always tell by the pci id though
20:08 imirkin: lspci -nn -d 10de: