20:45 Svanto: Hello hello!
20:45 Svanto: I seem to be having trouble with black screens on external monitors for some reason. Like it works on my laptop's internal, but not on the external connected to the GPU (which is connected to the laptop via thunderbolt)
20:45 Svanto: Is anybody else dealing with such?
20:47 imirkin: Svanto: weren't you already here asking about this?
20:47 imirkin: Svanto: and you noticed that it was a problem with wlroots?
20:48 imirkin: or do you mean DP link training over thunderbolt?
20:48 Svanto: It was a similar thing, but the wlroots thing got fixed ans now even TTY doesn't show up on the external monitor
20:48 imirkin: the latter is very finicky - make sure you have a good cable.
20:48 imirkin: a co-worker recently had an issue on intel hw which was resolved by changing cables.
20:48 imirkin: he couldn't get 4k@60 due to limited bandwdith
20:48 Svanto: It works on windows
20:49 Svanto: I'm thinking if even tty doesnt show up then it cant be sway/wlroots this time
20:49 imirkin: anything in dmesg?
20:49 imirkin: like "link training failed"?
20:49 Svanto: It could very well be KMS I imagine but thought I'd ask here first
20:50 Svanto: Ill check, but this is just a gpu connected via the pcie lanes the thunderbolt exposes
20:50 imirkin: oh
20:50 imirkin: this is an external GPU?
20:52 Svanto: yeah
20:59 karolherbst: it might also be set to PCIe 1.0 speeds
21:00 karolherbst: but 4k@60 is a bit broken, especially on HDR displays
21:00 karolherbst: or.. could be broken
21:04 Svanto: The internal monitor stuff definitely renders on the nouveau gpu, glxinfo says so
21:04 Svanto: Oh this looks sus
21:05 Svanto: DRM: failed to create encoder 1/8/0: -19
21:05 Svanto: DRM: Virtual-1 has no encoders, removinf
21:07 Svanto: There is also an error earlier stating bus: MMIO write of 800001f4 FAULT at 19eb14 [ PRIVRING ]
21:08 Svanto: And then it keeps sending alternating messages of DRM: base -1: timeout and DRM: base-0: timeout
21:09 karolherbst: Svanto: yeah.. that means we are configurung the hw wrong
21:09 karolherbst: Svanto: is this an HDR display?
21:09 imirkin: Svanto: the Virtual-1 thing isn't something to worry about
21:09 imirkin: the faults probably are
21:09 imirkin: and the DRM: base: timeout is "nothing works"
21:09 Svanto: Ahh I see
21:11 Svanto: karolherbst: I don't think they're HDR no, both are old, one is BenQ BL2411PT, other is E178Fpb
21:11 karolherbst: okay...
21:12 karolherbst: what kernel?
21:15 karolherbst: I actually have a eGPU case here, so I could check if I can reproduce the same bugs with a similiar GPU
21:16 Svanto: kernel is 5.12.15-arch1-1
21:42 karolherbst: what's the GPU?
21:46 Svanto: karolherbst: GTX 970
21:47 karolherbst: and is this via DP or HDMI?
21:49 Svanto: Displayport
23:27 mangix: Svanto: I remember hiding those warnings
23:27 mangix: weird that you get them
23:27 Svanto: which ones mangix
23:31 mangix: Svanto: virtual device thing. let me dig it up
23:31 Svanto: Ahh
23:32 mangix: https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?h=next-20210709&id=df00d5da609f59022ee9aafdb4e2313aefeb6bda
23:33 mangix: I take it that warning comes from X?